Skip to main content

TP-LINK TL-WR703N – Ersteinrichtung mit Open WRT

Meine neuste Errungenschaft ist der TL-WR703N von TP-LINK.

Da er leider nur mit einer chinesischen Firmware ausgeliefert wird führt wohl kein Weg an Open WRT vorbei. Im Folgenden erläutere ich das Vorgehen wie man Open WRT auf den Router bringt und die Ersteinrichtung vornimmt.

Zuerst den aktuellen Open WRT Snapshot für den Router runterladen: http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

Wenn Ihr auf der Routeroberfläche seid (IP-Adresse sowie Passwort und Benutzername ist unten am Gerät aufgedruckt) fahrt mit der Maus über die linke Navigation bis zum Eintrag “DateTimeCfgRpm.htm” und klickt diesen an.

Im aufgeklappten Menü sucht ihr dann den Eintrag “SoftwareUpgradeRpm.htm” und klickt diesen an.

Die nachfolgende Maske sollte dann kein Problem darstellen. Durchsuchen klicken, das heruntergeladene Image auswählen und auf Flashen klicken.

Nach ein paar Minuten solltet Ihr via telnet auf den Router zugreifen können. Password mit passwd ändern, telnet Verbindung mit exit beenden und Verbindung mittels ssh aufbauen. (Benutzername: root ; Passwort: das vorhin festgelegte)

Ich habe dann bei mir das Netzwerk ein bisschen bearbeitet. Einfach nachfolgend aufgeführte Datei mit dem vi bearbeiten.

/etc/config/network

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.0.1'
option netmask '255.255.255.0'
option dns '8.8.8.8'

 

Der nächste Schritt ist die Einrichtung des WLANs. Die Zeile “option disabled 1” habe ich auskommentiert, somit ist das WLAN aktiviert. Der Block “config wifi-iface” musst selbst hinzugefügt werden. Dabei wird die Betriebsart des Routers festgelegt (bei mir Access Point) sowie der Name, die Verschlüsselung und das Passwort hinterlegt.

/etc/config/wireless

config wifi-device radio0

option type mac80211
option channel 11
option macaddr ec:17:2f:9e:23:b4
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid WIRELESS_FREEDOM
option encryption psk2
option key 'password1234'

 

Auch sollte die Zeitzone noch angepasst werden.

/etc/config/system

config system

option hostname OpenWrt
option 'zonename' 'Europe/Berlin'
option 'timezone' 'CET-1CEST,M3.5.0,M10.5.0/3'

 

Somit ist die Ersteinrichtung abgeschlossen. Am besten noch ein

reboot

und alle Einstellungen sollten übernommen sein.

 

Leave a Reply

Your email address will not be published. Required fields are marked *