Skip to main content

UPDATE: Installation von Fritz!Load auf der Fritz!Box

Ich habe mir erlaubt ein kleines Script zu schreiben, welches die Installation vor allem für Einsteiger extrem erleichtert.

Zuerst eine Telnet Verbindung aufbauen und auf eure Festplatte oder USB Stick wechseln:

cd /var/media/ftp/FUJITSU-MHU2100AT-01/

Bei mir heißt die Platte “FUJITSU-MHU2100AT-01″, bei euch sicher anders. Gebt den Befehl einfach soweit ein
cd /var/media/ftp/

und drückt die TAB-Taste, dann wird automatisch vervollständigt, dann Enter drücken. In Putty könnt ihr Text oder Befehle übrigens mit der rechten Maustaste einfügen.

Danach gebt folgenden Befehl ein (Es ist eine Zeile, einfach kopieren, einfügen und Return drücken.):

wget http://download.thomasheinz.net/fritzbox/fritzload_installer.sh;chmod 777 fritzload_installer.sh;./fritzload_installer.sh

Daraufhin startet die Installation, folgt einfach den Anweisungen auf dem Bildschirm.

Ist alles glatt über die Bühne gegangen ist Fritz!Load danach unter folgender Adresse erreichbar: http://192.168.178.1/cgi-bin/fritzload/gui_download.cgi

WICHTIG: Achtet dann nach der Installation darauf, dass ihr den richtigen Downloadpfad einträgt. Zum Beispiel “/var/media/ftp/FUJITSU-MHU2100AT-01/fritzload/downloads/”.

 

110 thoughts to “UPDATE: Installation von Fritz!Load auf der Fritz!Box”

  1. Es liegt da schon. Aber anscheinend lässt Dropbox nur noch https Verbindungen zu, die versteht das wget der Fritz! Box aber wohl nicht

    //Edit: Hab es angepasst. Sollte wieder funktionieren.

  2. habe es installiert aber leider kommt immer
    Die angegebene URL wurde nicht gefunden. Sie werden auf die Startseite der FRITZ!Box weitergeleitet.

    Falls Sie nicht automatisch auf die Startseite der FRITZ!Box weitergeleitet werden, klicken Sie hier.

    habe die fritz.box 7330sl

    freetz geht jetzt auch nicht mehr

  3. Kann sein, dass es auf der 7330 nicht funktioniert. Ich hatte bis dato nur eine 7270. Hab aber auch seit kurzem eine 7362SL, da kann ich es in naher Zukunft mal ausprobieren.

  4. Ich habe Fritzbox 7490 mit FRITZ!OS 06.20
    Installation läuft ohne Fehlermeldung durch
    auf der USB Platte werden die Verzeichnisse und die Dateien angelegt
    im Menü der Box wird aber der Eintrag nicht erstellt und die URL ist nicht erreichbar
    mit der 6.05 lief es ohne Probleme

    Danke für die Rückmeldung

  5. Hallo,

    das Script ist nicht erreichbar.
    Bei der Fritzbox 730 6.05 ging alles tadellos.
    Seit dem Update auf die Version 6.20 wird selbst wenn die Url mit dem Script erreichbar ist und auch die Installation abgeschlossen ist, der Link im Fritzbox Menu nicht mehr angezeigt.

    Hoffe, dass Du zeit findest und eine Lösung zur Verfügung stellen kannst.

    Vielen Dank vorab.

    cu

    papadrellbo

  6. Gleiches Problem, nach der Installation ist kein Eintrag im Menü zu finden. Hat wohl was mit dem Neustart zu tun.

    Fritz!Box 7490
    FRITZ!OS 6.20

    Würde mich ebenfalls sehr über eine Lösung freuen.

    VG,
    Dario

  7. Danke für die tolle Anleitung/ das tolle Script.
    Jedoch das selbe Problem mit 6.20. Nach Downgrade auf 6.05 reboot (bootloop) alle 4-5 Minuten. Ich dachte schon, es liegt an dem Gerät und wäre defekt. Bin soeben wieder auf 6.20 hoch und warte auf dein Update. Werde bis dahin leider warten müssen und nichts machen.

    Wenn ich es installiere fehlt nach dem ersten Laden jegliche Formatierung der Seite und beim reboot funktioniert es gar nicht mehr.

    Vielen Dank und liebe Grüße

  8. Das Problem mit der Fritz!OS 6.20 ist bekannt. Nach jedem Reboot der Fritz!Box wird die debug.cfg gelöscht (worin der Befehl steht die Fritz!Load GUI neu zu laden). Soll vor Manipulation schützen. Das ganze kann umgangen werden indem man sich ein Script schreibt und dieses nach jedem Neustart der Fritz!Box ausführt oder es manuell über SSH oder telnet eingibt (zu finden hier: http://ryblog.eu/fritzload/viewtopic.php?id=320). Man kann auch das System der Fritz!Box verändern und damit wieder die Funktionalität der debug.cfg zurückholen (siehe http://www.ip-phone-forum.de/showthread.php?t=273304).

  9. Hi!
    ERstmal: Ein tolles Script ist das! Die Installation hat damit (wohl) auch geklappt.
    Ich habe nur das Problem das ich FritzLoad, weder im Menü der Box sehe, noch unter dem Link erreicht den Du bereitgestellt hast.
    Wo ist es hin?

    Danke:-)

  10. HI Alex,

    da bei neueren Fritz!Box OS der Autostart nicht mehr funktioniert (siehe Post über deinen) starte Fritz!Load zum test mit folgendem Befehl manuell:

    /var/media/ftp/USBSPEICHER/fritzload/bin/install.sh /var/media/ftp/USBSPEICHER/fritzload -g

    USBSPEICHER durch den Namen deines Speichers ersetzen. Danach solltest du es über den oben genannten Link aufrufen können.

  11. hi

    ich habe das selbe problem wie Alex
    nur auch mit deinen tipp klappt es bei mir trozdem nicht
    ich habe eine FB 7490 mit FRITZ!OS 06.23
    ich habe schon sämtliche anleitungen probiert und bekomm es einfach nicht zum laufen

    Hättest du evtl einen Tipp?

    mfg

  12. Hallo, ich habe eine Fritzbox von 1&1 (7390) mit OS 6.04. Ich habe schon damals mal Fritzload über diese ANleitung installiert, ging auch alles perfekt. Aber jetzt will es nicht so richtig. HDD wird erkannt. fritzload ornder wird durch die sh datei generiert und die Dateien ebenso gedownloaded, nur nach dem neustart ist kein fritzload eintrag im Menü. Wenn ich dann die install.sh im bin Ordner starte, so sieht man den Eintrag dann auch im Menü. Öffne ich dann fritzload oberfläche, so wird die zwar geöffnet, aber nicht richtig Dargestellt. Nach einem neustart ist alles auch schon wieder weg. Ich bemerkte, dass die debug.cfg datei wieder leer gemacht wird. Ich hörte es schon von usern mit der OS Version 6.20/6.23, aber wie schon geschrieben besitzte ich die 6.04. Hat da jemand eine idee? Ich habe auch den aktuellen Fritzload v0.42 runtergeladen und auf die festplatte gezogen. Dennoch das gleiche Problem 🙁

  13. Oder mit der 3370?

    Hatte es zwar wie hier (sourceforge.net/p/avmload/wiki/FritzLoadInstallation/) beschrieben installiert usw, aber mit ./install.sh -g passiert einfach nichts, mit fritz.box:90/cgi-bin/fritzload/gui_download.cgi erscheint einfach nichts.

  14. Update:
    Na toll, mit diesem konnte der FritzLoad doch geladen werden 🙂

    Siehe Beitrag von Tom:
    /var/media/ftp/Generic-FlashDisk-01/FritzLoad/bin/install.sh /var/media/ftp/Generic-FlashDisk-01/FritzLoad -g
    So kann doch mit fritz.box:90/cgi-bin/fritzload/gui_download.cgi die Weboberfläche manuell gestartet werden 🙂

  15. Hallo, also bei mir verschwinden die über USB angeschlossene Geräte sofort nachdem ich tenet.tar als Firmware einspiele, somit ist alles weitere nicht mehr möglich. Telnet lässt sich aktivieren und per Putty kann ich die Fritzbox erreichen. Nach dem Neustart von Fritzbox sind USB-Geräte wieder da, aber Telnet ist ja nicht mehr da. Warum ist es so und was kann ich dagegen unternehmen?
    Beim erstem mal hat aber scheinbar etwas teilweise geklappt, ich finde auf der Festplatte ein Verzeichniss “Fritzload”, aber unter http://192.168.178.1/cgi-bin/fritzload/gui_download.cgi ist nichts…

  16. Hi Tom,

    ich hab dich vor 2 Jahren oder so schonmal genervt. Seitdem läuft FritzLoad dank deinem Skript bei mir problemlos.

    Nun habe ich eine Zweitwohnung in der vom Vermieter ein Router zur Verfügung gestellt wird. Die FritzBox 7362 SL läuft auf der neuesten Firmware. Das Problem, dass dort die Telnet-Schnittstelle geblockt ist konnte ich bereits durch eine Custom-Firmware lösen. Als Shell in a box konnte ich dann dein Skript durchführen und habe Fritzload in den internen Speicher der Box direkt unter /var/fritzload/ eingespielt. Auf meiner Heimat-Box läuft das auch so.

    Dummerweise läuft nach erfolgreicher Installation Fritzload bzw. die GUI nicht. Die Adresse ist nicht erreichbar. Beim manuellen Starten per Befehl erhalte ich folgenden Fehler:

    /var/media/ftp/fritzload/bin/install.sh /var/media/ftp/fritzload -g
    /var/media/ftp/fritzload/bin/install.sh: line 375: /var/media/ftp/fritzload/bin/guiinit.sh: not found

    Ich habe mir auch schon die debug.cfg angeschaut, kann dort jedoch keinen Fehler entdecken:

    #Fritz!Load starten
    while !(/var/media/ftp/fritzload/bin/install.sh /var/media/ftp/fritzload -g); do sleep 5; done

    Mehr steht dort nicht drin.

    Hast du adhoc eine Idee, woran es liegen könnte? Telnet funktioniert per Shell in a box noch, reicht das zur Ausführung von Fritzload? Oder muss ich an der Firmware 06.30 noch irgendwas anpassen, um die GUI zum Laufen zu bewegen?

    Dank dir im Voraus für dein Fachwissen =)

    Beste Grüße

    Chris

Leave a Reply

Your email address will not be published. Required fields are marked *