Skip to main content

TP-LINK TL-WR703N – OpenWRT: Wireless Client Mode

Im folgenden beschreibe ich kurz wie Ihr euren TP-LINK TL-WR703N als Wireless Client einrichtet.

Installiert zuerst die Pakete relayd und luci-proto-relay.

Danach passt Ihr die Datei /etc/config/network folgendermaßen an:

config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

config interface 'lan'
 option ifname 'eth0'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.1.2'
 option netmask '255.255.255.0'

config interface 'wwan'
 option _orig_ifname 'wlan0'
 option _orig_bridge 'false'
 option proto 'static'
 option ipaddr '192.168.178.3'
 option netmask '255.255.255.0'
 option gateway '192.168.178.1'
 option dns '8.8.8.8'

Passt die IP-Adressen bitte an euer Netzwerk an.

Die Datei /etc/config/wireless sollte folgendes enthalten:

 config wifi-device radio0
 option type mac80211
 option channel 6
 option macaddr ec:17:2f:9e:23:b4
 option hwmode 11ng
 option htmode HT20
 list ht_capab SHORT-GI-20
 list ht_capab SHORT-GI-40
 list ht_capab RX-STBC1
 list ht_capab DSSS_CCK-40
 # REMOVE THIS LINE TO ENABLE WIFI:
 #option disabled 1

config wifi-iface
 option device radio0
 option network wwan
 option mode sta
 option ssid Networkname
 option encryption psk2
 option key pa$$w0rd

Natürlich auch wieder an euer Netzwerk anpassen (z.B. Channel, Name, Verschlüsselung, Passwort)

Ich habe bei meinem TP Link dnsmasq, iptables und die firewall deinstalliert, ist nach meiner Ansicht nach unnötig wenn das Gerät nur als Wireless Client agiert.

Abschließend noch

/etc/init.d/relayd enable

ausführen und danach den TP-Link neustarten. Er sollte sich jetzt via WLAN mit eurem Netzwerk verbinden.

4 thoughts to “TP-LINK TL-WR703N – OpenWRT: Wireless Client Mode”

Leave a Reply

Your email address will not be published. Required fields are marked *