Skip to main content

Easybox 904 xDSL – OpenWRT flashen und mit beliebigen Anbieter nutzen (VDSL mit Vectoring)

Ich hatte noch eine Easybox 904 xDSL im Schrank liegen. So einfach funktioniert die Box aber nicht mit einem anderen Anbieter. Und bevor man mit sich mit der Vodafone Firmware rumärgert, ist es wohl besser gleich OpenWRT / LEDE zu flashen. Das ist auch gar nicht so tragisch. Es gibt fertige Images im Internet (wie immer, auf eigenes Risko flashen, man weiß nie was drin ist. 😉 Sicher kann man nur sein, wenn man selbst kompiliert und die Sourcen prüft.)

Ich habe mich an dieser Anleitung orientiert: https://openwrt.org/toh/astoria/arcadyan_astoria_easybox_904xdsl_r01#installing_openwrt_the_easy_way

Als TFTP Server habe ich TFTPD32 unter Windows genutzt, zum Download hier entlang: http://tftpd32.jounin.net/tftpd32_download.html

Danach konfiguriert ihr euer Ethernet Netzwerk Interface auf die IP 192.168.2.100

TFTPD als Admin starten:

Habe mir dann (nach persönlichen Geschmack) das root-Verzeichnis geändert, sowie die Bind Address ausgewählt (wenn die IP nicht stimmt, habt ihr euer Netzwerk Interface nicht richtig konfiguriert).

In das root-Verzeichnis legt ihr dann das zuvor heruntergeladene fullimage.img ab. Mittels “Show Dir” überprüft ihr, ob die Datei tatsächlich korrekt liegt und erkannt wird:

Sieht es so aus, kann es weitergehen. Die Easybox mittels LAN-Kabel mit euerem Windows Rechner verbinden. Jetzt die Easybox mit gedrückten Reset-Knopf einschalten und den Reset-Knopf mindestens 10 Sekunden gedrückt halten.

Es sollte folgendes Bild auf der Easybox erscheinen, also hier könnt ihr nun wirklich den Reset-Knopf loslassen. Ich habe die 10-12 Sekunden einfach eingehalten und gut war’s.

Im Anschluss seht ihr dann folgendes:

Die Box wird dann eine Meldung zum Neustart anzeigen. Schaltet die Box aus und dann wieder an. Bei mir hat der DHCP Server keine Adresse rausgerückt, habe daher die IP manuell konfiguriert, zum weiteren Vorgehen. Auf jeden Fall müsst ihr die bisherige Konfiguration aus dem Netzwerk Interface entfernen, dann auf DHCP hoffen oder wie folgt konfigurieren:

Greift dann via Browser auf http://192.168.1.1/ zu.

Jetzt könnt ihr das sysupgrade image flashen, dies ist auch in der Wiki-Seite verlinkt. Habe auch mit diesem Image gute Erfahrungen gemacht, da ist ne ganze Menge schon reinkompiliert: https://github.com/zuzia-dev/Easybox-904xDSL

In meinem verwendeten Image war keine VDSL Vectoring fähige Firmware enthalten. Habe deshalb ein image von hier https://xdarklight.github.io/lantiq-xdsl-firmware-info/ heruntergeladen und wie beschrieben die Firmware extrahiert. (lantiq-vrx200-b.bin)

Die DSL Konfiguration sieht bei mir folgendermaßen aus (/etc/config/network)

Man beachte, dass ich die VDSL Firmware unter /overlay/upper/lib/firmware/ abgelegt habe. Die DSL settings passen auf die Telekom mit VLAN 7. Ihr müsst nur noch die korrekten Zugangsdaten angeben.

config atm-bridge 'atm'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'
        option vci '32'
        option vpi '1'
 
config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '0'
        option firmware '/overlay/upper/lib/firmware/lantiq-vrx200-b.bin'
 
config interface 'wan'
        option proto 'pppoe'
        option username 'xxxx@t-online.de'
        option password 'xxx'
        option ifname 'dsl0.7'
        option mtu '1492'
        option ipv6 'auto'

Ach ja, das WLAN lässt sich wohl nur über die CLI konfigurieren. Die wireless config (/etc/config/wireless):

#WiFi 5 GHz:
config wifi-device 'wl000'
	option type 'ralink'
	option channel '36'
	option legacy_rates '0'
	option htmode 'VHT40'
	option disabled '0'

config wifi-iface 'default_wl000'
	option device 'wl000'
	option mode 'ap'
	option ssid 'EasyBOX5GHz'
	option encryption 'psk2+aes'
	option key 'WiFipassword'
	option network 'lan'
	option disabled '0'

#WiFi 2.4 GHz:
config wifi-device 'wl010'
	option type 'ralink'
	option channel '11'
	option legacy_rates '0'
	option htmode 'VHT40'
	option disabled '0'

config wifi-iface 'default_wl010'
	option device 'wl010'
	option mode 'ap'
	option ssid 'EasyBOX2.4GHz'
	option encryption 'psk2+aes'
	option key 'WiFipassword'
	option network 'lan'
	option disabled '0'

Und den “hacked bootloader” hab ich bei mir auch noch drübergebügelt: https://openwrt.org/toh/astoria/arcadyan_astoria_easybox_904xdsl_r01#installing_hacked_bootloader

Leave a Reply

Your email address will not be published. Required fields are marked *